Skip to main content

Mettre à jour Ubuntu de Dapper à Edgy avec apt-get

Mettre à jour Ubuntu de Dapper à Edgy avec apt-get

Geoffrey Carr

Note importante: Selon l'aide Ubuntu:

S'il vous plaît noter - cette méthode est beaucoup moins fiable. Si vous utilisez cette méthode, vous DEVEZ être prêt à résoudre les problèmes manuellement, tels que la suppression inattendue de packages. L'utilisation de Update Manager sera probablement beaucoup moins problématique.

Avant de lire ce Guide, vous souhaiterez peut-être envisager une installation à l'aide de l'interface graphique avec Update Manager, qui est probablement une méthode plus simple pour les utilisateurs habituels.

Si vous êtes un utilisateur expérimenté, passons à autre chose. Premièrement, nous devrons installer ubuntu-desktop s’il n’est pas déjà installé, sinon un problème de dépendance se présentera.

sudo apt-get install ubuntu-desktop

Nous devons maintenant exécuter une commande qui modifiera toutes les occurrences de dapper en édifiant dans notre fichier sources.list. Si vous ne le connaissez pas, sources.list est le fichier qui pointe vers votre liste de mises à niveau et de packages possibles. Pour les utilisateurs de Windows, vous pouvez le considérer comme le fichier qui pointe vers Windows Update. Bien sûr, si vous êtes un utilisateur Windows, vous devriez vraiment installer avec l'utilitaire Update Manager lié ci-dessus.

sudo sed -e ‘s/sdapper/ edgy/g’ -i /etc/apt/sources.list

Nous allons maintenant effectuer les mises à niveau réelles:

sudo apt-get update && sudo apt-get dist-upgrade

La partie && de la commande signifie que la deuxième commande sera exécutée après la première tant que la première commande aboutira.

Nous allons maintenant terminer la mise à niveau avec quelques commandes supplémentaires:

sudo apt-get -f install

sudo dpkg –configure -a

Notez que la configuration est en réalité deux tirets. Pour une raison quelconque, WordPress fait ressembler à un tiret unique. Redémarrez et vous avez terminé!

Remarque: certaines notes indiquent que cette mise à niveau ne fonctionne pas très bien pour les utilisateurs d’Ubuntu en tant qu’invité dans VMWare avec les outils VMWare installés. Je l'ai testé et suis arrivé à la même conclusion, pas de solution pour l'instant.

Mettre à jour:

Si la mise à niveau vous donne le message d'erreur «Échec du chargement du module GLcore», vous voudrez exécuter ces commandes. Merci pour cette astuce à Biogeek dans les commentaires ci-dessous.

apt-get install xfs apt-get install –reinstall xfonts-base

Link
Plus
Send
Send
Pin